Back to overview
Downtime
Major Outage
May 19, 2026 at 9:10pm UTC
Affected services
Realm VTT
Resolved
May 20, 2026 at 1:30am UTC
Service was restored by our hosting provider.
Affected services
Created
May 19, 2026 at 9:10pm UTC
Our hosting provider suffered a major outage for 3 hours on 5/19 that impacted our services.
Affected services